-=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- (c) WidthPadding Industries 1987 0|685|0 -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=- -=+=-
Socoder -> Web Development -> NectarJS - It's Easy!

Posted : Tuesday, 27 July 2021, 07:35

NectarJS - It's Easy!

Thought I'd look into using WASM to speed things up a bit in JSE.
A quick search over the net suggested NectarJS was the way to go.
Converts JS to Wasm! Easy!! SIMPLES!!!

Seems easy enough.

Day One

I installed NectarJS easily.
This is a lie, it took about 3 hours.
True, some of that was because of recent MacOS updates, but even still, come on guys..

Day Two

I wrote a test .js file, and ran NectarJS on it, and indeed it did output the "console.log("Hello World");" to the console.
Things were looking up!
Next, I tried compiling it to wasm, using the "--env wasm" parameter.

It failed.

Why did it fail?
Because I didn't have *nnngh*Emscripten*nnngh* installed..

Day Three

With emscripten installed, and a giant 5Gb chunk of my precious SSD space somehow missing, I tried once more and!!
Bingo!! Now I have a .wasm file. Just like all the "easy to follow" tutorials suggested!

It's now 2:30 in the afternoon, and I've spent since about 11'ish trying over and over and over and over and over again to find out WHAT THE FUCK AM I SUPPOSED TO DO WITH THAT FILE!?!?

I tried every tutorial I could find (barely any) and they all resulted in the same set of errors in the browser.
It seems Emscripten is compiling with the wrong set of parameters, binding extra/less things or something, so the resulting .wasm is unusable without a suitable index.html/.js fine to go with it..
.. But nectar also isn't passing parameters to generate those.

This is fucking stupid.
I'm very ranty and angry and grrr.
Fuxake people, if you're going to make a tool, at least leave a fucking example next to it.

''Load, Next List!''
Posted : Tuesday, 27 July 2021, 09:05
I have no clue about Wasm either. I could use it for Raylib and Wonkey but it just seems like hell to get working. With Monkey2 it was doable as I just needed to unpack a prepared zip from mark into the dev folder.

With Godot is just seems to be all working without any trouble or installing.